ENG Новый сайт

Расширенный поиск

[ Новые сообщения · Пользователи · Правила ]
Страница 20 из 51«1218192021225051»
Форум » SpaceEngine » Проблемы и их решения » Разные ошибки, баги, глюки (Обсуждение ошибок в работе программы и путей их решения)
Разные ошибки, баги, глюки
SpaceEngineerДата: Четверг, 07.04.2011, 00:41 | Сообщение # 1
Автор Space Engine
Группа: Администраторы
Российская Федерация
Сообщений: 5547
Награды: 54
Статус: Offline
Пишите сюда про обнаруженные баги и глюки.

Но перед этим прочитайте про известные ошибки и способы их устранения.

Формат сообщения об ошибке:

1) Словесное описание ошибки и ситуации, при которой она возникла.
2) Характеристики вашей системы: процессор, ОЗУ, видеокарта и объём её памяти.
3) Прикреплённый к сообщению лог-файл. Он находится в папке программы и называется se.log

Вопросы типа "прога не запускается, винда 7, что делать!" не принимаются, т.к. не несут никакой полезной информации. Вопросы без лог-файла не принимаются.


GV_FiQstДата: Пятница, 14.10.2011, 02:34 | Сообщение # 286
Строитель Миров
Группа: Команда SE
Украина
Сообщений: 1062
Награды: 3
Статус: Offline
Летал по галактике, "упал".
AMD Phenom II X2 555 3.2 GHz;
ОЗУ 1333 GHz 4096 Mb
VIDEO Radeon HD 5670 1024 Mb

После этого:
я нажимаю на пкм и от че получается


5842220.log - До
8080915.log - После
Прикрепления: 5842220.log(38Kb) · 1894872.jpg(39Kb) · 8080915.log(12Kb)


AMD Phenom II X2 555 3200 MHz;
RAM 4GB 1333 Hz;
ATI Radeon HD 5670 1024 Mb;
ОС Win 7 tabulorasa edition 32 bit


Сообщение отредактировал GV_FiQst - Пятница, 14.10.2011, 02:48
1997Дата: Пятница, 14.10.2011, 17:27 | Сообщение # 287
Исследователь
Группа: Пользователи
Российская Федерация
Сообщений: 218
Награды: 0
Статус: Offline
Не у меня точная видеопамять в скрине
Прикрепления: 5391974.jpg(219Kb)


...
SpaceEngineerДата: Пятница, 14.10.2011, 17:54 | Сообщение # 288
Автор Space Engine
Группа: Администраторы
Российская Федерация
Сообщений: 5547
Награды: 54
Статус: Offline
GV_FiQst, какие-то глюки с координатами планеты или к чему была привязана камера. Если перезапуск не помогает, обнули координаты и имя объекта привязки в конфиге user.cfg

1997, 512 - это ОЗУ, а видео судя по логу у вас 256. Не пора ли обновить железо? smile


1997Дата: Пятница, 14.10.2011, 17:58 | Сообщение # 289
Исследователь
Группа: Пользователи
Российская Федерация
Сообщений: 218
Награды: 0
Статус: Offline
А как его обновить?

...
GV_FiQstДата: Пятница, 14.10.2011, 18:55 | Сообщение # 290
Строитель Миров
Группа: Команда SE
Украина
Сообщений: 1062
Награды: 3
Статус: Offline
1997, Имеется ввиду купить новый компютер или установить более мощные видеокарту и ОЗУ (оперативка) biggrin

SpaceEngineer, Зашел user.cfg. Смотрю в last user position и не понимаю что за координаты:
Code
UserRefBody       ""  // reference body name
UserRefBodyParent ""   // reference body's parent name
UserPosition  (1.#QNAN0000000000e+000, 1.#QNAN0000000000e+000, 1.#QNAN0000000000e+000)  // coordinates relative to ref body center
UserRotation  (1.#QNAN0000000000e+000, 1.#QNAN0000000000e+000, 1.#QNAN0000000000e+000, 1.#QNAN0000000000e+000)    // orientation quaternion
UserVelocity  1.000000000000000e+000    // default velocity
UserDate      "2000.01.01 12:14:00.45"    // Greenwich time
UserMode      "Free"     // binding mode: Free/Follow/SyncRot
UserTimeScale 1       // time scale


Здесь менять?


AMD Phenom II X2 555 3200 MHz;
RAM 4GB 1333 Hz;
ATI Radeon HD 5670 1024 Mb;
ОС Win 7 tabulorasa edition 32 bit


Сообщение отредактировал GV_FiQst - Пятница, 14.10.2011, 19:00
SpaceEngineerДата: Пятница, 14.10.2011, 19:52 | Сообщение # 291
Автор Space Engine
Группа: Администраторы
Российская Федерация
Сообщений: 5547
Награды: 54
Статус: Offline
Да, поменяй UserPosition и UserRotation на нули. Вообще-то новая версия должна игнорировать наны, щас проверю что происходит.

GV_FiQstДата: Пятница, 14.10.2011, 21:23 | Сообщение # 292
Строитель Миров
Группа: Команда SE
Украина
Сообщений: 1062
Награды: 3
Статус: Offline
Quote (SpaceEngineer)
Да, поменяй UserPosition и UserRotation на нули.

не помогло.

но я знаю что поможет. просто когда выбывает ошыбка полететь вперед.


AMD Phenom II X2 555 3200 MHz;
RAM 4GB 1333 Hz;
ATI Radeon HD 5670 1024 Mb;
ОС Win 7 tabulorasa edition 32 bit
SpaceEngineerДата: Пятница, 14.10.2011, 22:20 | Сообщение # 293
Автор Space Engine
Группа: Администраторы
Российская Федерация
Сообщений: 5547
Награды: 54
Статус: Offline
Должно помочь.

Code

UserRefBody       "Sol"  // reference body name   
   UserRefBodyParent ""   // reference body's parent name   
   UserPosition  (0, 0, 0,)  // coordinates relative to ref body center   
   UserRotation  (1, 0, 0, 0)    // orientation quaternion   
   UserVelocity  1.000000000000000e+000    // default velocity   
   UserDate      "2000.01.01 12:14:00.45"    // Greenwich time   
   UserMode      "Free"     // binding mode: Free/Follow/SyncRot   
   UserTimeScale 1       // time scale


А, да, кватернион то единичный надо сделать.

UPD: Вообще-то SE при загрузке если не может считать нормальные числа из конфига, автоматом делает координаты нулевыми, а кватрнион ориентации единичным. Специально сейчас проверил код.


GV_FiQstДата: Суббота, 15.10.2011, 00:23 | Сообщение # 294
Строитель Миров
Группа: Команда SE
Украина
Сообщений: 1062
Награды: 3
Статус: Offline
все помогло, баг больше не возникает biggrin

AMD Phenom II X2 555 3200 MHz;
RAM 4GB 1333 Hz;
ATI Radeon HD 5670 1024 Mb;
ОС Win 7 tabulorasa edition 32 bit
GV_FiQstДата: Воскресенье, 16.10.2011, 21:58 | Сообщение # 295
Строитель Миров
Группа: Команда SE
Украина
Сообщений: 1062
Награды: 3
Статус: Offline
У меня такое: Линии орбит за планетами, оно так и должно быть или я что-то наделал???

Прикрепления: 9698559.jpg(200Kb)


AMD Phenom II X2 555 3200 MHz;
RAM 4GB 1333 Hz;
ATI Radeon HD 5670 1024 Mb;
ОС Win 7 tabulorasa edition 32 bit


Сообщение отредактировал GV_FiQst - Воскресенье, 16.10.2011, 21:59
SpaceEngineerДата: Воскресенье, 16.10.2011, 23:42 | Сообщение # 296
Автор Space Engine
Группа: Администраторы
Российская Федерация
Сообщений: 5547
Награды: 54
Статус: Offline
Так должно быть.

EugenДата: Понедельник, 24.10.2011, 20:11 | Сообщение # 297
Нет аватара
Космонавт
Группа: Команда SE
Российская Федерация
Сообщений: 59
Награды: 0
Статус: Offline
Вот небольшой баг: три астероида просвечивают через планету.



Intel Core 2 Duo CPU E8400, 3.00 ГГц
2.00 Гб ОЗУ
NVIDIA GeForce 9600 GT (512 Мб)
Windows XP SP2
AerospacefagДата: Вторник, 25.10.2011, 01:00 | Сообщение # 298
Строитель Миров
Группа: Пользователи
Российская Федерация
Сообщений: 1019
Награды: 3
Статус: Offline
Eugen,
Quote (SpaceEngineer)
Так должно быть.

<irony>


Win7
Intel Core i5-2310 2.9 Ghz
4 Gb DIMM DDR3
Asus GeForce GTX760, 2 Gb GDDR-5
SpaceEngineerДата: Вторник, 25.10.2011, 05:14 | Сообщение # 299
Автор Space Engine
Группа: Администраторы
Российская Федерация
Сообщений: 5547
Награды: 54
Статус: Offline
Вроде исправил это.

darkplutoДата: Суббота, 29.10.2011, 14:40 | Сообщение # 300
Нет аватара
Наблюдатель
Группа: Новички
Российская Федерация
Сообщений: 1
Награды: 0
Статус: Offline
попробовал у себя на лептопе. очень понравилось, классная прога. очень понравилась огромная скорость передвижения и количество галактик со звёздами. можно лететь со скоростью 1,2 с мимо планеты и наблюдать как это бы было в реальности, класс.
только не могу понять почему уровень детализации планеты не из солнечной системы при приближении к поверхности у меня какойто низкий, ниже чем на скринах тут на сайте. не знаю как это исправить.

ещё есть предложение, возникло так как уже искал раньше подобный софт. есть такой софт там посмотрите видео. правда он у меня не работает поэтому сужу только по видео. там к примеру кольца как у сатурна но при приближении появляются отдельные процедурные камушки из которых они состоят, при этом даже на самих камушках кратеры горки и всякие мелкие неровности при приближении. нельзя ли чтонибуть подобное реализовать.
Форум » SpaceEngine » Проблемы и их решения » Разные ошибки, баги, глюки (Обсуждение ошибок в работе программы и путей их решения)
Страница 20 из 51«1218192021225051»
Поиск:

>